Announcement

Collapse
No announcement yet.

1JZ / GZ20 speedo fault...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1JZ / GZ20 speedo fault...

    The 1jz has been in my z20 for about 18months now. But the speedo only reads about 1/4 of the road speed.

    Has anyone else had this problem?

    How can I fix it?


    ie. When Im doing 60kmh, my speedo reads 15

    The engine is coming out soon, so hopefully I can trace the problem down to a simple wiring glitch or something because when i play with the speed signal on my Greddy EMU ECU, it does not change a darn thing....
    Pulled apart and gone: 400rwhp JZZ20
    Member Thread: http://www.z20soarer.org/forums/showthread.php?t=162

  • #2
    What gearbox are you running and what speedo sender on the gearbox did you use when you did the swap?

    You can re-use the digital sender from the A340e auto box and it bolts straight into the W series gearboxes and should provider the correct signal.
    Moo

    Comment


    • #3
      It's an A340e Box with sender. 3 wire plug on the sender.
      Pulled apart and gone: 400rwhp JZZ20
      Member Thread: http://www.z20soarer.org/forums/showthread.php?t=162

      Comment


      • #4
        yeah loonie's right ryan.. You need to use the 1g speedo sender, not the 1j one. The gear ratio's on each are different by a mile..

        JZZ20 1988 Soarer GT Twin Turbo
        1JZ-GTE + R154 + Garrett T04S/External Gate + 550cc + Bosch 040 + KoyoRad + Custom Plenum + 90mm TB + Kaaz 1.5Way + Cusco Comp-S + Cusco Strut Brace + Nightpager 4 Pot Conversion + HID's [GZ 20 WA]
        | Black Knight
        JZX90 1993 Mark II Tourer V Sugoi Ne~! | 270rwhp of Green Apple Splatters!
        GDB 2003 Subaru Impreza WRX Stock and in MINT Unmolested Condition.
        B7 2005 Audi A4 TFSI Quattro Turbo Keepin My Pimp Hand Strong.

        Comment


        • #5
          Are you sure just swapping the sender is gonna work? As far as i know, the A340e Uses a magnetic sensor that picks up signals from the outputshaft.

          I know the Z20/A70 body's use 20 teeth on the outputshaft per revelation. The tranny that came with my V8 uses Z30/A80 signal, wich only use 4 teeth per revelation, so my speedo is fooked atm. Will be ok when i swap in a R154 though

          Comment


          • #6
            Hmm, Im waiting to hear back from a guy in toymods about a sender.
            Anybody have a spare one?
            Pulled apart and gone: 400rwhp JZZ20
            Member Thread: http://www.z20soarer.org/forums/showthread.php?t=162

            Comment


            • #7
              i had one. not now though

              Comment


              • #8
                well thats no help... HAHA. all good :P
                I'll find one. Hopefully asap while the engine is out.
                Pulled apart and gone: 400rwhp JZZ20
                Member Thread: http://www.z20soarer.org/forums/showthread.php?t=162

                Comment


                • #9
                  i shud have one if your still keen ill look tomorow
                  http://garageslipway.wordpress.com/sigpic

                  Comment


                  • #10
                    Yeah mate, definately if i can get one in beofre the engine goes back in that would be excellent.
                    Pulled apart and gone: 400rwhp JZZ20
                    Member Thread: http://www.z20soarer.org/forums/showthread.php?t=162

                    Comment


                    • #11
                      how long till your motor goes back in i definatly have one just need to go take it off
                      http://garageslipway.wordpress.com/sigpic

                      Comment


                      • #12
                        weeks. my guess is 4 weeks. my target is to get it up and running ready for a big drag meet up here (muscle vs rice)
                        i just pulled mine out of the gearbox just then, it has a 3 pin oval plug, a thick silver shaft, and a yellowish gear on the end with like, i dunno, 20 or so teeth on it. i can put up a pic maybe if i can figure out how to :P
                        Pulled apart and gone: 400rwhp JZZ20
                        Member Thread: http://www.z20soarer.org/forums/showthread.php?t=162

                        Comment

                        Working...
                        X