Announcement

Collapse
No announcement yet.

Smoke coming from turbos?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Smoke coming from turbos?

    Hey guys. I've recently been doing a basic service on my 86 Auto 1G-GTE (so gen 2 I believe?) and just put it back together and started it for a drive this afternoon. It blew a bit of smoke for the first couple of seconds but I know I would've dropped a fair bit of oil down the plug wells when I changed over my old plugs (there was heaps of oil around the wells due to a leaky cam cover gasket which was also fixed). I noticed it was idling really high (about 2k rpms) at first. I left it to idle for maybe 2 minutes and it dropped to about 1.4k.
    When I was driving it for the first little bit I noticed that there was a bit of a burning oil smell, I figured that was just a tiny bit of oil left in the cylinders as it went away pretty quickly. So it was all going good until I decided to try and open it up. I put it in first gear and gave it to her, got to about 4-5k and then heard a "pop", it was like a backfire but way quieter. Car stalled and I pulled over, popped the hood and there was a fair amount (not plume or anything) of white smoke (not blue) coming from the back of the turbo but it looked like it was under the turbo. It all blew away in like a second so I couldn't really get a good glimpse. Saw that the cool side intercooler hose had popped off the pipe.
    So I put it back on because I was only like 50m from my house lol and fired up the bus again and it ran normally. Does anyone know what this could be? I'm really not hoping it's a turbo seal or blown head gasket.
    86 mica red GZ20 manual

  • #2
    How does the car drive now? Is it still making power and coming onto boost as it did before or is it different?
    .
    - Complete English z20 Wiring Diagrams
    - All Circuits
    - Every Connector
    - Completely in English.

    Comment


    • #3
      I only had it idling for like 2 minutes so not too sure what it's like with load on it. I'm changing the intercooler pipes because they are pretty crappy looking and the hose clamps have cut into them a fair way from just loosening and re tightening during its life.
      What do you think it could be?
      Cheers.
      86 mica red GZ20 manual

      Comment


      • #4
        Not sure but if something has failed then you'll know it if you drive it again, take it for a spin and see if it behaves differently to how it did before the accident. See if the car has all it's power like it did before.

        Let us know how you go
        .
        - Complete English z20 Wiring Diagrams
        - All Circuits
        - Every Connector
        - Completely in English.

        Comment


        • #5
          I've been driving it as per normal, no difference No idea what happened but no harm. The car is its usual old slow self :P
          86 mica red GZ20 manual

          Comment


          • #6
            I changed the oil in my car and got the same results, im going to be changing the valve stem seals as normally that's what oil on start-up does. Ill let you know the outcome once I get off my butt and do it.

            Comment

            Working...
            X